SKY3DS10.0

Confirmed! SKY3DS can support newest 3DS V10.0.0-27U/E/J/K

Nintendo 3DSV10.0.0-27 released and this update mainly applies to New Nintendo 3DS XL, Nintendo 3DS, Nintendo 3DS XL, Nintendo 2DS.

As they always do, SKY3DS teams announce that sky3ds can support newest 3DS V10.0.0-27U/E/J/K. When this new update comes out, we have upgrade our 3DS console to 3DSV10.0. We tested with sky3ds flashcard blue button, and found that sky3dsĀ  works well on 3DS10.0.

* It’s confirmed! SKY3DS can support newest 3DS V10.0.0-27U/E/J/K! (09/09/2015)